Slow loading and timeouts caused by Network Connectivity Issues
Incident Report for Freckle Time Tracking
Resolved
This incident has been resolved.
Posted 8 months ago. Mar 23, 2018 - 18:26 EDT
Monitoring
Freckle's hosting provider is currently experiencing network connectivity issues. They have implemented a fix, and we are monitoring the status of their fix. We'll let you know as soon as the issue has been resolved!
Posted 8 months ago. Mar 23, 2018 - 15:45 EDT