Slow loading and timeouts
Incident Report for Freckle Time Tracking
Resolved
Sorry about the timeouts! A fix has been implemented and we're monitoring the servers to make sure everything's working.
Posted 16 days ago. Feb 04, 2019 - 09:49 EST
Investigating
We're looking into Freckle being very slow to load or timing out completely.
Posted 16 days ago. Feb 04, 2019 - 09:44 EST
This incident affected: Freckle Web App and Freckle API.