Slow loading and timeouts
Incident Report for Freckle Time Tracking
Resolved
We've solved the timeouts and slowdowns, and will continue to monitor the app.
Posted about 1 month ago. Oct 16, 2018 - 00:54 EDT
Investigating
We're looking into Freckle being very slow to load or timing out completely.
Posted about 1 month ago. Oct 16, 2018 - 00:47 EDT
This incident affected: Freckle Web App and Freckle API.