Freckle is down and not loading
Incident Report for Freckle Time Tracking
Resolved
Freckle is back up after our hosting provider experienced a temporary network outage. Our ops team will continue to monitor the app.
Posted about 1 year ago. Jun 13, 2016 - 01:34 EDT
Monitoring
Freckle is back up, but we're continuing to investigate the root cause and monitor the app.
Posted about 1 year ago. Jun 13, 2016 - 01:11 EDT
Investigating
Freckle is down and not loading. We're identifying the root cause right now and will keep you posted.
Posted about 1 year ago. Jun 13, 2016 - 01:00 EDT