Increased API latency
Incident Report for Freckle Time Tracking
Resolved
The underlying reason of API latency was an API client issuing too many requests for large sets of entries. As a temporary fix we've reached out to the affected customer and they've reduced the amount of requests issued. In the longer term, we're working on better caching for the more popular API methods; this will all but eliminate latency issues like this one.
Posted about 1 year ago. Mar 24, 2016 - 10:06 EDT
Investigating
We're seeing some slow-downs in processing API requests. The API is still functioning fully, but response times are slow for some types of API calls.
Posted about 1 year ago. Mar 24, 2016 - 06:55 EDT