Slow loading and timeouts
Incident Report for Freckle Time Tracking
Resolved
This incident has been resolved.
Posted 8 days ago. Jun 14, 2017 - 13:48 EDT
Monitoring
We've implemented a fix to improve Freckle's overall performance, and are monitoring the results.
Posted 8 days ago. Jun 14, 2017 - 12:43 EDT
Investigating
We're looking into Freckle being very slow to load or timing out completely.
Posted 8 days ago. Jun 14, 2017 - 11:44 EDT