Freckle is down
Incident Report for Freckle Time Tracking
Resolved
We're all back and Freckle works normally. We're still researching the root cause of this problem.
Posted almost 3 years ago. Dec 27, 2013 - 17:39 EDT
Investigating
Freckle is down and not working at the moment. We are investigating the cause.
Posted almost 3 years ago. Dec 27, 2013 - 17:31 EDT
This incident affected: Freckle Web App.