Partial outage of Freckle
Incident Report for Freckle Time Tracking
Resolved
Performance is back to normal. This problem was caused by an issue with Freckle API, which we have identified and will roll out a fix very soon. We'll keep on monitoring'.
Posted almost 3 years ago. Nov 25, 2013 - 17:13 EDT
Investigating
We're investigating.
Posted almost 3 years ago. Nov 25, 2013 - 16:57 EDT
This incident affected: Freckle Web App.