Timers not working correctly
Incident Report for Freckle Time Tracking
Resolved
The Timer will no longer display bogus "disconnected" alerts. Please be sure to reload your timer window or simply close and open it again.
Posted over 3 years ago. Mar 27, 2013 - 11:26 EDT
Investigating
We're looking into a problem with the Freckle Timer not working correctly.
Posted over 3 years ago. Mar 27, 2013 - 11:15 EDT