Freckle is currently down
Incident Report for Freckle Time Tracking
Resolved
Freckle is back and up and running!
Posted over 3 years ago. Jul 05, 2013 - 09:43 EDT
Investigating
We're investigating the cause.
Posted over 3 years ago. Jul 05, 2013 - 09:40 EDT