Developer website not reachable
Incident Report for Freckle Time Tracking
Resolved
This incident has been resolved.
Posted over 1 year ago. Jul 06, 2015 - 18:39 EDT
Identified
Due to issues with our upstream DNS provider the http://developer.letsfreckle.com is currently not available at least for some customers. See also https://www.cloudflarestatus.com/incidents/m8hf8q8vs81d
Posted over 1 year ago. Jul 06, 2015 - 17:37 EDT