Slow loading and timeouts
Incident Report for Freckle Time Tracking
Resolved
Freckle is back! There was a queued process using up too much memory causing a server load issue. We're working on a fix to prevent this from happening again in the future.
Posted over 2 years ago. Feb 21, 2014 - 17:28 EDT
Investigating
We're looking into Freckle being very slow to load or timing out completely.
Posted over 2 years ago. Feb 21, 2014 - 17:18 EDT