CDN issues preventing Freckle from being displayed correctly
Incident Report for Freckle Time Tracking
Resolved
Issues with Amazon's CloudFlare DNS not resolving have been fixed by Amazon. Happy Thanksgiving!
Posted almost 2 years ago. Nov 26, 2014 - 21:37 EDT
Update
Freckle is back—we've temporarily disabled Amazon CloudFront. Loading times will be a bit slower and we're seeing some Avatars not being loading, but everything else should work. We'll restore CDN functionality once Amazon CloudFront gets fixed.
Posted almost 2 years ago. Nov 26, 2014 - 20:23 EDT
Update
CloudFront DNS seems to be down again. We're preparing a workaround should this situation not be resolved by Amazon in 10-15 minutes.
Posted almost 2 years ago. Nov 26, 2014 - 19:59 EDT
Monitoring
For some users, Freckle has returned to loading normally. The root cause of this outage was that Amazon Cloudfront's DNS entries couldn't be resolved. It appears that DNS is coming back online for it. There's no word from Amazon, so we're watching the situation. It might take a while to work for you as DNS changes propagate.
Posted almost 2 years ago. Nov 26, 2014 - 19:54 EDT
Update
Note: Freckle is down, because JavaScript can't be served as well. We're monitoring and have a fallback strategy in case Amazon CloudFront is not coming back up soon.
Posted almost 2 years ago. Nov 26, 2014 - 19:45 EDT
Investigating
Our CDN (Amazon CloudFront) appears to be offline, unfortunately affecting serving of stylesheets and graphics for Freckle. We're looking into this problem right now.
Posted almost 2 years ago. Nov 26, 2014 - 19:41 EDT