Freckle is currently down
Incident Report for Freckle Time Tracking
Resolved
All systems are go—the unicorns are prancing once more! :)
Posted almost 3 years ago. Nov 07, 2013 - 12:04 EDT
Investigating
Freckle is down and we're investigating the issue.
Posted almost 3 years ago. Nov 07, 2013 - 12:00 EDT
This incident affected: Freckle Web App.