Posted about 3 years ago. Sep 19, 2013 - 00:49 EDT
Monitoring
Homepage and blog are back! While all should be good now, we're monitoring this and will keep you posted.
Posted about 3 years ago. Sep 19, 2013 - 00:48 EDT
Investigating
The Freckle homepage and blog are currently down and we're investigating the cause. The Freckle app itself is not affected—you can use your Freckle account normally.
Posted about 3 years ago. Sep 19, 2013 - 00:36 EDT