Unexpected downtime due to deploying problem
Incident Report for Freckle Time Tracking
Resolved
Freckle is back, all systems go!
Posted about 3 years ago. Sep 08, 2013 - 10:28 EDT
Investigating
We're experiencing some unexpected downtime during a routine deploy and are investigating.
Posted about 3 years ago. Sep 08, 2013 - 10:23 EDT