Freckle is down due to a deployment issue
Incident Report for Freckle Time Tracking
Resolved
All systems go! :)
Posted almost 2 years ago. Dec 15, 2014 - 15:29 EDT
Identified
After a deployment Freckle is not available, we're looking into the root cause.
Posted almost 2 years ago. Dec 15, 2014 - 15:25 EDT