We've finished our maintenance. All systems go! :)
Posted over 2 years ago. Apr 08, 2014 - 08:09 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted over 2 years ago. Apr 08, 2014 - 08:00 EDT
Scheduled
We'll be updating server software which will require taking Freckle offline for a very short period of time (we expect this to last less than a minute).